La présentation est en train de télécharger. S'il vous plaît, attendez

La présentation est en train de télécharger. S'il vous plaît, attendez

Algorithmes et structures de données Cours 3 Patrick Reuter

Présentations similaires


Présentation au sujet: "Algorithmes et structures de données Cours 3 Patrick Reuter"— Transcription de la présentation:

1 Algorithmes et structures de données Cours 3 Patrick Reuter

2 Variables Permet de stocker des données au cours dun algorithme Structure de données la plus élémenataire Caractérisé par leur nom et leur type

3 Variables Caractérisé par leur nom et leur type Nom : x y z i pointsJoueur1 pointsJoueur2 somme

4 Ingrédients dalgorithmes Affectation Condition/Comparaison Structure de contrôle –Branchements conditionnels (multiples) –Boucles Bloc dinstruction Appel de fonction

5 Ingrédients dalgorithmes Affectation x 10; y := 30; z = x;

6 Faire tourner un algorithme Affectation x := 10; y := 30; z := x; x := 20 x y 30 Chaque variable une colonne z 10

7 Ingrédients dalgorithmes Comparaison a = 7 points > meilleurpoints absent = FAUX malade = VRAI OU vacances = VRAI a=7 ET b=5 -Note: -Le résultat dune condition/comparaison peut être uniquement soit VRAI, soit FAUX

8 Ingrédients dalgorithmes Structure de contrôle –Branchements conditionnels SI ALORS [SINON ] Exemple : a := 3; b := 4; c := 10; SI a >b ALORS c := 20; SINON c := 5;

9 Ingrédients dalgorithmes Structure de contrôle –Branchements conditionnels SI ALORS SINON Exemple : a := 3; b := 4; c := 10; SI a >b ALORS c := 20; SINON c := 5; b4b4 Chaque variable une colonne c 10 5 a3a3

10 Ingrédients dalgorithmes Structure de contrôle –Branchements conditionnels SI (mois = 1) ALORS nom := "Janvier" ; SINON si (mois = 2) ALORS nom := "Février"; SINON si (mois = 3) ALORS nom := "Mars"; SINON si (mois = 4) ALORS nom := "Avril"; SINON si (mois = 5) ALORS nom := "Mai"; SINON si (mois = 6) ALORS nom := "Juin"; … SINON si (mois = 12) ALORS nom := "Décembre"; SINON afficher('Erreur dans le mois') ;

11 Ingrédients dalgorithmes Structure de contrôle –Branchements conditionnels multiples –CAS mois DE 1: nom := "Janvier" ; 2: nom := "Février"; 3: nom := "Mars"; 4: nom := "Avril" ; 5: nom := "Mai" ; …. 12: nom := "Décembre" ; AUTREMENT afficher('Erreur dans le mois') ; FIN CAS;

13 Calculer : somme := ;

14 somme :=0; i:=1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1;

15 somme :=0; i:=1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme i123456i123456

16 Ingrédients dalgorithmes Structure de contrôle –Boucle Définition : Suite dinstructions qui peut être exécuté plusieurs fois (itération)

17 Ingrédients dalgorithmes Structure de contrôle –Boucle TANT QUE FAIRE FIN TANT QUE

18 somme :=0; i:=1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme i123456i123456

19 somme :=0; i:=1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme i123456i123456

20 somme :=0; i:=1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme :=0; i:=1; TANT QUE FAIRE somme := somme + i; i:=i+1; FIN TANT QUE

21 somme :=0; i:=1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme := somme + i; i:=i+1; somme :=0; i:=1; TANT QUE i <= n FAIRE somme := somme + i; i:=i+1; FIN TANT QUE

22 somme i123456i somme :=0; i:=1; TANT QUE i <= 5 FAIRE somme := somme + i; i:=i+1; FIN TANT QUE


Télécharger ppt "Algorithmes et structures de données Cours 3 Patrick Reuter"

Présentations similaires


Annonces Google