La présentation est en train de télécharger. S'il vous plaît, attendez

La présentation est en train de télécharger. S'il vous plaît, attendez

1 ALGORITHMIQUE. 2 Quest-ce quun algorithme ? « écrire un algorithme », cest : Analyser et comprendre le problème : étudier les données fournies et les.

Présentations similaires


Présentation au sujet: "1 ALGORITHMIQUE. 2 Quest-ce quun algorithme ? « écrire un algorithme », cest : Analyser et comprendre le problème : étudier les données fournies et les."— Transcription de la présentation:

1 1 ALGORITHMIQUE

2 2 Quest-ce quun algorithme ? « écrire un algorithme », cest : Analyser et comprendre le problème : étudier les données fournies et les résultats attendus Résoudre le problème, cest trouver les structures de données adaptées ainsi que lenchaînement des actions à réaliser pour passer des données aux résultats Cet algorithme sera ensuite converti à laide dun langage de programmation.

3 3 Quest-ce quun algorithme ? Un algorithme correspond à la description dun processus logique écrit en langage naturel décrivant une succession dopérations à exécuter dans un certain ordre et sous certaines conditions, pour passer des données de base aux résultats

4 4 Quest-ce quun algorithme ? Lalgorithmique est la technique des algorithmes Un algorithme décrit un traitement selon une logique et un formalisme rigoureux. Lalgo prépare la programmation Lalgo est une étape préalable indispensable à la réalisation dun bon programme Cest une méthode de découpage dun traitement en instructions élémentaires

5 5 Caractéristiques dun algorithme Il contient plusieurs séquences à exécuter Ensemble dactions élémentaires les séquences (étapes) se succèdent dans un certain ordre Il peut éventuellement exister une répétition (itération) ou une condition dexécution ou non de certaines séquences Il est caractérisé par un début et une fin

6 6 La structure dun algorithme En général, un algo comprend 4 parties : 1. la déclaration des variables nécessaires aux traitements 2. linitialisation des variables : affectation de valeurs initiales aux variables déclarées

7 7 La structure dun algorithme 3. Le traitement des différentes séquences ordonnées de lalgo : Réalisation dactions élémentaires ou structurées Appel de procédures ou de fonctions externes 4. À la fin de lalgo, la sortie des résultats et larrêt de lalgo

8 8 Les objets utilisés dans lalgo Un algo utilise des objets qui peuvent être des variables, des constantes. Chaque objet à un rôle qui consiste à mémoriser une valeur particulière significative : La variable contient une valeur appelée à être modifiée au cours de l'algorithme. La constante qui retient une valeur qui ne change pas au cours de l'algorithme Un objet est parfaitement défini sil est parfaitement identifié, typé et renseigné

9 9 a) caractéristiques dune variable Une variable est un dispositif de mémorisation dune valeur à laquelle on accède à tout moment. Elle est caractérisée par : Un rôle : signification attribuée à la variable Un nom (identificateur) : « contenant » permettant daccéder directement à son contenu. Il doit être le plus parlant et le plus évocateur du rôle de la variable Une valeur : contenu de la variable à un moment donné Variables de type élémentaire : contient 1 seule valeur Variables de type tableau : contient plusieurs valeurs contenues dans un tableau déclaré dans un seul type Un type : cest la définition du domaine dans lequel une variable peut puiser sa valeur

10 10 b) Tableau de déclaration de variables N°NomStatut (Entrée ou Sortie) RôleType (Entier, réel, texte, date, booléen) Format 1CodecliECode du client entier111 2datfactEDate de la facture datejj/mm/aaaa 3anciencliEAncien clientBooléenOui / non 4NomcliENom du client Texte40 car …

11 11 Les règles de mise en forme de lalgorithme Nom de lalgorithme Début Déclaration des variables et constantes Initialisation des variables Instructions1 Instructions 2 Fin Traitement

12 12 Les actions élémentaires: Affecter une variable consiste a lui donner une valeur. Cette valeur peut être soit une constante, soit une valeur dune autre variable, soit le résultat dun calcul. Exemple : Si A est une variable de type Byte (valeur comprise entre 0 et 255), on peut écrire : A 3, A 3 + 4, A 2*B, A (B*B)/C Le symbole est le symbole daffectation Si une variable est numérique A 0 Si une variable est chaîne de caractères A "0", ou A " Lettres " Les affectations

13 13 Les instructions élémentaires La primitive dentrée ou saisir (entrée clavier) et lire (lecture en provenant du disque dur). Le but de ces primitives est de permettre a lordinateur daffecter une variable extérieure a une autre variable. Le nom de cette variable symbolise une adresse en mémoire centrale. A cette adresse se trouve la valeur, a un moment donne de la variable. La primitive de sortie : écrire, afficher, imprimer. Le but est de permettre a lordinateur de sortir la valeur dune variable vers les périphériques extérieurs (écran, imprimante, etc…) Lentrée dinformation La Sortie dinformations

14 14 Exemple dalgo Ex Algo : Facture Début Constantes: TX_TVA : 0,196 Variables Ref, Nb : Entier Pu_ht, Brut_HT, : Réel Entrée des données élémentaires SAISIR « référence de la bouteille ? », Ref SAISIR « Prix HT dune bouteille ? », Pu SAISIR « Combien de bouteilles achetées ?, Nb * Calcul du montant dû par le client Brut_HT Pu * Nb * Sortie des résultats Afficher "Montant dû par le client:", Brut_HT etc. Fin

15 15 Les outils Les structures alternatives Elles permettent de vérifier la valeur logique dune expression. Lobjectif sera de réaliser certaines actions en fonction de cette valeur. La structure de base est la suivante : Si (condition est vraie) Alors Action 1 Sinon Action 2 Fin Si Une action peut être un calcul, une affectation ou une autre condition.

16 16 La structure alternative Alternative appauvrie : Si « condition » Alors « Action 1 » Fin Si

17 17 La structure alternative Si code_sexe = 1 Alors Genre <- « masculin » Sinon Genre <- « féminin » Fins si La vérification de la valeur booléenne de lexpression se fera en utilisant des opérateurs relationnels et logiques tels que : > ; = ; <> ; <= sont des opérateurs relationnels = comparaison Et, ou sont des opérateurs Logiques

18 18 Exemple dalgo Algo : Début Constantes: TXTVA : 0,196 Variables Ref, Nb : Entier Pu, BrutHT, Rem, NetHT, netTTC,tva : Réel * Entrée des données élémentaire SAISIR « référence de la bouteille ? », Ref SAISIR « Prix HT dune bouteille ? », Pu SAISIR « Combien de bouteilles achetées de cette référence ?, Nb * Calcul du montant dû par le clientCalcul du montant dû par le client ….. * Sortie des résultats Afficher "Montant dû par le client:", NetTTC Fin

19 19 Exemple dalgo – niveau 2 * Calcul du montant dû par le client * *Calcul du montant de la remise BrutHT Pu * Nb Si Nb >= 24 Alors Rem BrutHT * 0,05 Sinon Rem 0 Fin Si * *Calcul du montant net HT NetHT BrutHT – Rem ** Calcul du montant net TTC TvA NetHt*txttva NetTTC NetHT + tva

20 20 Structure Imbriquée Une structure alternative peut être de nature imbriquée. Si (condition est vraie) Alors Action 1 Si (condition est vraie) Alors Action 1.1 Sinon Action 1.2 Fin si Sinon Action 2 Fin si

21 21 Exemple : Si code_sexe = 1 Alors Si âge >= 18 Alors Personnes = « majeur » Genre = « masculin » Sinon Personnes = « mineur » Genre = « masculin » Fin Si Sinon Si âge >= 18 Alors Personnes = « majeur » Genre = « féminin » Sinon Personnes = « mineur » Genre = « féminin » Fin si Fin Si

22 22 Autre possibilité Si code_sexe = 1 et âge >= 18 Alors Personnes = « majeur » Genre = « masculin » Sinon Personnes = « majeur » Genre = « masculin » Fin si Si code_sexe = 2 et age >= 18 Alors Personnes = « majeur » Genre = « féminin » Sinon Personnes = « mineur » Genre = « féminin» Fin si

23 23 Variante de la structure alternative pour remplacer avantageusement la structure alternative (SI..ALORS…SINON…), quand il y a un grand nombre de cas possibles selon les valeurs que peut prendre une variable, on peut utiliser la structure SELON CAS : Selon Cas Cas Cas … Cas Sinon Fin selon Voir exemple : calcul des frais réelsexemple

24 24 ALGO calcul des frais de déplacement Variables : Nbkm : entier Puissance : entier Tarif : réel Frais : réel Saisir « puissance fiscale du véhicule :», puissance Saisir « nombre de kilomètres parcourus :», nbkm * Calcul des frais * Affichage des résultats Afficher « le montant des frais de déplacement est de :», frais Si nbkm <= 100 Alors frais 0 Sinon Selon Cas puissance Cas 1 à 3 tarif = 1 Cas 4 à 6 tarif = 1.5 Cas 7 à 8 tarif = 2 Cas 9 à 12 tarif = 2.5 Cas Est > 12 tarif = 3 Cas Sinon tarif = 0 Fin Selon frais tarif * nbkm Fin Si

25 25 Exercice Excel

26 26 Les structures itératives Une structure itérative permet de répéter une suite dinstructions autant de fois que lon veut (notion de boucle). Différentes structures permettent de réaliser cette forme de traitement : Pour Tant que Répéter, jusqu'à ce que

27 27 Structure itérative Pour On sait a lavance combien de fois on veut itérer. Pour i de 1 a 10. Faire Actions Fin Pour (i i+1) Il faut donc connaître la valeur de début de i ainsi que sa valeur darrivée. A chaque tour de boucle, la variable i sera incrémentée (augmentée) de 1.

28 28 La structure «POUR… FIN POUR» Algo : Début TOTALTTC, CumulTTC, TVA, prix : réel ref : chaine NB : entier i : entier CumulTTC 0 SAISIR « nombre de PRODUITS achetés : », NB * répétition du calcul du montant dû pour POUR i = 1 à NB totalHT 0 : Tva 0 : TOTALTTC 0 Saisir Ref, Pu, Qt totalHt Pu*QT Tva totalht* 0,196 TOTALTTC TOTALht+ tva CumulTTC CumulTTC+TOTALTTC FIN POUR AFFICHER «montant total TTC facturé et dû par le client », CumulTTC Fin

29 29 Structure itérative Tant que Tant que la Condition est vraie alors les actions seront executées. Déclarer réponse : chaîne Réponse «oui » ( Initialisation) Tant que reponse = "oui " Faire Actions Saisir Réponse Fin Tant que

30 30 … Début * TOTALTTC : réel TOTALTTC 0 Ref: chaine SAISIR « Quelle est la référence des bouteilles achetées ? », Ref * répétition du calcul du montant dû pour TANT QUE Ref <> " " FAIRE * Entrée des autres données élémentaires Pu, Nb * * Calcul du montant de la remiseCalcul du montant de la remise * * Calcul du montant net HT * * Calcul du montant net TTC TOTALTTC TOTALTTC + NETTTC Saisir « Autre référence de bouteille :», ref FIN TANT QUE AFFICHER «montant total TTC facturé et dû par le client », TOTALTTC Fin

31 31 … Début * TOTALTTC : réel Ref, Rep: chaine TOTALTTC 0 Rep "OUI " TANT QUE Rep = OUI " FAIRE * Entrée des autres données élémentaires Pu, Nb, Ref * * Calcul du montant de la remiseCalcul du montant de la remise * * Calcul du montant net HT * * Calcul du montant net TTC TOTALTTC TOTALTTC + NETTTC Saisir Autre Saisie oui/non :, Rep FIN TANT QUE AFFICHER «montant total TTC facturé et dû par le client », TOTALTTC Fin

32 32 Structure itérative Répéter jusqu'à ce que Répéter laction jusquà ce que condition devient fausse Déclarer réponse = chaîne Répéter Action(S) Saisir réponse Jusqu'à ce que réponse soit vraie

33 33 Début * TOTALTTC : réel Réponse : chaîne TOTALTTC 0 * répétition du calcul du montant dû pour REPETER * Entrée des autres données élémentaires Ref, Pu, Nb Etc. TOTALTTC TOTALTTC + NETTTC Saisir «Y-a-t-il une autre référence de bouteille :», réponse JUSQUÀ réponse = "NON " AFFICHER «montant total TTC facturé et dû par le client », TOTALTTC Fin

34 34 Procédures et fonctions Sont des séquences dactions qui seront nommées et dans des algorithmes auxiliaires. Ces procédures et fonctions seront appelées à partir d un algorithme principal.

35 35 Les procédures Une procédure est un algo auxiliaire qui contient une séquence dactions : La procédure est désignée par un nom La procédure est appelée, une ou plusieurs fois, dans un ou plusieurs algos principaux. La procédure a besoin de variables élémentaires déclarées dans lalgo principal ( les variables ont une portée globale ) La procédure renvoie ou non, dans lalgorithme principal, un ou plusieurs résultats contenus dans des variables déclarées dans lalgo principal

36 36 Lintérêt dutiliser des procédures est de permettre une plus grande lisibilité de lalgo principal (appelant) : Gain de temps car cela évite décrire plusieurs fois la même chose. lalgo auxiliaire peut être appelé dans plusieurs algos principaux : Mise à jour plus aisée de lalgo principal : Réduction du risque derreur car seul lalgo appelant est modifié

37 37 Private Sub Cmd_calc_Fahr_Click() Procedure_Faren_Cel MsgBox "La temperature est de " & f & "degres F." End Sub Private Sub Procedure_Faren_Cel() f = (Txt_valeur * 9 / 5) + 32 End Sub

38 38 Private Sub cmd_test_Click() Proc_calc_fahr (Txt_valeur) MsgBox "La temperature est de " & celsius & "degres C." End SuB Private Sub Proc_calc_fahr(degre As Single) celsius = (degre - 32) * 5 / 9 End Sub

39 39 Les fonctions Une fonction est une procédure particulière qui ne renvoie, dans lalgorithme principal, quun et un seul résultat. La fonction est appelée dans lalgorithme principal, directement dans une instruction : en général, elle apparaît dans la partie droite dune affectation Lors de son appel, la fonction est évaluée à partir darguments qui lui sont fournis le résultat vient se substituer au nom de la fonction dans lexpression appelante

40 40 Les fonctions Toute utilisation de la fonction nécessite donc deux spécifications : 1.Un nom 2.Un ou plusieurs paramètre Exemple : déduction1 fraisforfait (somme)

41 41 Les fonctions Il existe deux catégories de fonctions : 1.Les fonctions standards : fonctions de base offertes par le langage utilisé 2.Les fonctions utilisateurs : lutilisateur devra développer ses propres fonctions à partir du langage utilisé. En effet, elles doivent répondre à un besoin précis et elles ne seront pas disponibles dans la bibliothèque du langage de programmation utilisé…

42 42 Fonction VB Function fahr(Cel As Integer) As Single fahr = (Cel * 9 / 5) + 32 End Function Appel de la Fonction Private Sub Cmd_calc_Fahr_Click() MsgBox "La Temperature est de " & fahr(Txt_cel) & " degres C." End Sub

43 43 La notion de variables tableaux ( Vecteur 1 dimension) Dans un algo, il est possible quune variable puisse contenir à un moment donné, non pas une valeur, mais plusieurs valeurs à la fois. Il sagit dans ce cas dune variable TABLEAU Un tableau est une variable qui permet de stocker des valeurs de même type. Chaque valeur est repérée par un indice indiquant sa position dans le tableau

44 44 VECTEURS et TABLEAUX

45 45 La déclaration de variables tableaux Un tableau doit avoir : un nom déclaré comme un type particulier de données Une dimension connue à lavance : La dimension correspond au nombre maximum de cases composant le tableau ou le Vecteur Un indice doit être déclaré pour permettre dadresser les différentes cases du tableau. Lindice est obligatoirement du type entier NOMTABLEAU [nbvaleurmax] : type (préciser aussi le rôle de la variable tableau) i : entier (indice)

46 46 Lutilisation de variables tableaux Un tableau peut être à 1 ou 2 dimensions. Laccès à lélément dun tableau seffectue : En précisant la position relative de lélément par rapport au début du tableau. En utilisant le ou les indices

47 47 Algo Fonction version 1 du calcul des frais réels SI NBKM <= 100 ALORS déduction1 = 0 SINON Selon Cas puissanceF Cas 1 à 3 tarif = 0,1 Cas 4 à 6 tarif = 0,15 Cas 7 à 8 tarif = 0,25 Cas 9 à 12 tarif = 0,4 Cas Est > 12 tarif = 0.5 Cas SINON tarif = 0 Fin Selon Déduction1 = tarif * NBKM FIN SI Algo fonction version 2 du calcul des frais réels *déclaration du tableau Tarif tarif [13] : tableau de 13 réels i : entier * Initialisation des valeurs du tableau Tarif[1] = 0.1 Tarif[2] = 0.1 Tarif[3] = 0.1 Tarif[4] = 0.15 Tarif[5] = 0.15 Tarif[6] = 0.15 calcul de la déduction au frais réels SI NBKM <= 100 ALORS déduction1 = 0 SINON SI puissanceF > 13 ALORS i = 13 SINON i = puissanceF FIN SI Déduction1 = Tarif(i) * NBKM FIN SI Tarif[7] = 0.25 Tarif[8] = 0.25 Tarif[9] = 0.3 Tarif[10] = 0.3 Tarif[11] = 0.3 Tarif[12] = 0.3 Tarif[13] = 0.5

48 48 Lutilisation de variables tableaux Exemple de tableau à 2 dimensions : Pour déterminer le forfait de location applicable selon la catégorie du véhicule loué ET la période de location choisie, nous pouvons utiliser un tableau à 2 dimensions (voir version 2) contenant toutes les valeurs applicables au forfait de location du véhicule, au lieu dutiliser la structure SELON CAS (version 1) …

49 49 La notion de variables tableaux ( Vecteur 1 dimension) Dans un algo, il est possible quune variable puisse contenir à un moment donné, non pas une valeur, mais plusieurs valeurs à la fois. Il sagit dans ce cas dune variable TABLEAU Un tableau est une variable qui permet de stocker des valeurs de même type. Chaque valeur est repérée par un indice indiquant sa position dans le tableau

50 50 Algo fonction version 2 Fonction forfait(categ, typeloc) *déclaration du tableau à 2 dimensions TABFORLOC : tableau de 16 réels categ : entier (indice de colonne) typeloc : entier (indice de ligne) * Initialisation des valeurs du tableau TABFORLOC[1,1] = 75 TABFORLOC[1,2] = 126 TABFORLOC[1,3] = 291 TABFORLOC[1,4] = 650 TABFORLOC[2,1] = 82 TABFORLOC[2,2] = 155 TABFORLOC[2,3] = 338 TABFORLOC[2,4] = 700 * choix de la valeur renvoyée dans la fonction grâce aux indices Forfait = TABFORLOC[categ,typeloc] FIN Fonction Algo Fonction version 1 Fonction forfait(categ, typeloc) SI categ = 1 ALORS Selon Cas typeloc Cas 1 forfait = 75 Cas 2 forfait = 126 Cas 3 forfait = 291 Cas 4 forfait = 650 Fin Selon SINON SI categ = 2 ALORS Selon Cas typeloc … Fin Selon SINON SI categ = 3 ALORS Selon Cas typeloc … Fin Selon SINON SI categ = 4 ALORS Selon Cas typeloc … Fin Selon SINON forfait = 0 FIN SI FIN FONCTION TABFORLOC[3,1] = 129 TABFORLOC[3,2] = 219 TABFORLOC[3,3] = 519 TABFORLOC[3,4] = 1000 TABFORLOC[4,1] = 105 TABFORLOC[4,2] = 180 TABFORLOC[4,3] = 411 TABFORLOC[4,4] =880

51 51 procédures et fonctions Dans le principe, un bon algorithme ne devrait pas dépasser une page ! Pour respecter ce principe, il convient de NOMMER certaines séquences dactions qui correspondront à des procédures ou à des fonctionsprocédures fonctions Ainsi, ces actions nommées seront décrites dans des algorithmes auxiliaires et seront utilisées dans un algorithme principal.

52 52 Les procédures Une procédure est un algo auxiliaire qui contient une séquence dactions : La procédure est désignée par un nom La procédure est appelée, une ou plusieurs fois, dans un ou plusieurs algos principaux. La procédure a besoin de variables élémentaires déclarées dans lalgo principal La procédure renvoie, dans lalgorithme principal, un ou plusieurs résultats contenus dans des variables déclarées dans lalgo principal

53 53 Lintérêt dutiliser des procédures est de permettre une plus grande lisibilité de lalgo principal (appelant) : Gain de temps car cela évite décrire plusieurs fois la même chose. lalgo auxiliaire peut être appelé dans plusieurs algos principaux : Mise à jour plus aisée de lalgo principal : Réduction du risque derreur car seul lalgo appelant est modifié

54 54 Exemple vb Option Explicit Dim f As Single Private Sub Cmd_calc_Fahr_Click() Procedure_Faren_Cel MsgBox "La temperature est de " & f & "degres F." End Sub Private Sub Procedure_Faren_Cel() f = (Txt_valeur * 9 / 5) + 32 End Sub

55 55 Procédure et passage de paramètre Option Explicit Dim celsius As Single Private Sub cmd_test_Click() Proc_calc_fahr (Txt_valeur) MsgBox "La temperature est de " & celsius & "degres C." End Sub Private Sub Proc_calc_fahr(degre As Single) celsius = (degre - 32) * 5 / 9 End Sub

56 56 Les fonctions Une fonction est une procédure particulière qui ne renvoie, dans lalgorithme principal, quun et un seul résultat. La fonction est appelée dans lalgorithme principal, directement dans une instruction : en général, elle apparaît dans la partie droite dune affectation Lors de son appel, la fonction est évaluée à partir darguments qui lui sont fournis le résultat vient se substituer au nom de la fonction dans lexpression appelante

57 57 Les fonctions Toute utilisation de la fonction nécessite donc deux spécifications : 1.Un nom 2.Un ou plusieurs paramètres Exemple : déduction fraisforfait (somme)

58 58 Les fonctions Il existe deux catégories de fonctions : 1.Les fonctions standards : fonctions de base offertes par le langage utilisé 2.Les fonctions utilisateurs : lutilisateur devra développer ses propres fonctions à partir du langage utilisé. En effet, elles doivent répondre à un besoin précis et elles ne seront pas disponibles dans la bibliothèque du langage de programmation utilisé…

59 59 Fonction VB Appel de la Fonction Private Sub Cmd_calc_Fahr_Click() MsgBox "La Temperature est de " & fahr(Txt_cel) & " degres C." End Sub Function fahr(Cel As Integer) As Single fahr = (Cel * 9 / 5) + 32 End Function

60 60 FIN du cours dalgo


Télécharger ppt "1 ALGORITHMIQUE. 2 Quest-ce quun algorithme ? « écrire un algorithme », cest : Analyser et comprendre le problème : étudier les données fournies et les."

Présentations similaires


Annonces Google