La présentation est en train de télécharger. S'il vous plaît, attendez

La présentation est en train de télécharger. S'il vous plaît, attendez

Plan : I.Introduction II.La structure itérative complète III.Les structures itératives à condition darrêt IV.exercices Chap. 4 Leçon 2 Les Structures de.

Présentations similaires


Présentation au sujet: "Plan : I.Introduction II.La structure itérative complète III.Les structures itératives à condition darrêt IV.exercices Chap. 4 Leçon 2 Les Structures de."— Transcription de la présentation:

1 Plan : I.Introduction II.La structure itérative complète III.Les structures itératives à condition darrêt IV.exercices Chap. 4 Leçon 2 Les Structures de contrôles itératives

2 Dans les chapitres précédents nous avons appris à faire des programmes calculant des résultats dont le nombre est petit, mais ceci est insuffisant lorsque le même traitement se répète plusieurs fois et les résultats se multiplient. Doù la nécessité des structures itératives (ou répétitives). Soit les exemples suivants : Exemple 1 : Un élève veut vider son cartable qui contient 5 cahiers. Si on analyse cet exemple on verra quil y a un traitement ( tirer un cahier) qui va se répéter un nombre connu de fois (égale à 5). On peut résumé ça en : Pour i de 1 à 5 répéter tirer un cahier Fin pour I- Introduction

3 Exemple 2 : Un élève veut vider son cartable qui contient un nombre inconnu de cahiers. Si on analyse cet exemple on verra quil y a deux méthodes possibles : On vérifie si le cartable est vide (la condition darrêt du traitement) si oui on ne va rien faire si non on va tirer un cahier ( le traitement à faire) et on va répéter ca jusquà ce que le cartable soit vide. on peut résumé ça en : tant que ( cartable non vide ) faire tirer un cahier fin tant que On tire un cahier (on a supposé depuis le début que le cartable nest pas vide) puis on vérifie si le cartable est vide ou non sinon on répète le même traitement jusquà ce quil soit vide.

4 on peut résumé ça en : répéter tirer un cahier jusquà (cartable vide) Daprès ces exemples on peut dire quil existe deux structure itératives : Structure itérative complète où le nombre ditérations est connu à lavance Structure itératives à condition darrêt où le nombre ditérations nest pas connu à lavance

5 * La structure Répéter ….jusquà : a) Syntaxe : Analyse [init] répéter traitement jusquà (condition(s) darrêt) Algorithme …………. …………. Init Répéter traitement jusquà (condition(s) darrêt) Pascal ………….; …………. ; Init Repeat traitement Until (condition(s) darrêt); b) Remarques : On utilise cette structure de répétition si le nombre e répétition est inconnu à lavance. Larrêt du traitement est générer si la(les) condition(s) darrêt = vraie; Le traitement itératif doit sexécuter au moins une fois. II- Structure Itérative a condition darrêt

6 * La boucle tant que ….faire : a) Syntaxe : Analyse [init] tantque non (condition(s) darrêt) faire traitement fin tantque Algorithme …………. …………. Init tantque non (condition(s) darrêt) traitement Fin tantque Pascal ………….; …………. ; Init While non (condition(s) darrêt) do traitement; b) Remarques : On utilise cette structure de répétition si le nombre de répétition est inconnu à lavance. Larrêt du traitement est générer si la(les) condition(s) darrêt = faux; Le traitement itératif peut ne pas sexécuter.

7 a) Application 1: soit lalgorithme suivant : 0)debut inconnu 1)lire(ch) 2)Lire(car) 3)[trouve<-faux; i<-0] repeter i<-i+1 si ch[i]=car alors trouve<- vrai finsi jusquà (trouve ou (i=long(ch)) 4) Si (trouve) alors ecrire(car, dans,ch) sinon ecrire(car,non dans, ch) 5) Fin inconnu Travail à faire : A- dans quel cas utilise ton une structure répétitive à condition darrêt? B- Donner une comparaison entre les deux structures répétitives Tant que.. Faire et Répéter..jusquà III- Applications

8 C- Réécrire lalgorithme ci-dessus tout en remplaçant la boucle répéter …jusquà par la boucle Tant que..Faire D- Quel est le rôle de ce programme E- Traduire cet algorithme en Pascal b) Application 2 : Ecrire une analyse, un algorithme et un programme Pascal permettant de saisir une entier de 3 chiffres et dafficher si cest un nombre cubique ou non. Un nombre est dit cubique sil est égale à la somme des cubes de ses chiffres( exemple 153= ).


Télécharger ppt "Plan : I.Introduction II.La structure itérative complète III.Les structures itératives à condition darrêt IV.exercices Chap. 4 Leçon 2 Les Structures de."

Présentations similaires


Annonces Google