= 18) ALORS prix <- 100 SINON prix <- 60 FINSI message <- "Vous devez " + "prix" + " francs" ECRIRE (message) FIN PROGRAMME SI (taille <= 100) ALORS prix <- 0 SINON SI (jour = "SA") OU (jour = "DI") ALORS prix <- 100 SINON SI (age > = 18) ALORS prix <- 100 SINON prix <- 60 FINSI ECRIRE ('Quel est votre age ?") LIRE (age) ECRIRE ('Quel est votre taille ?") LIRE (taille) ECRIRE ('Quel est le jour de la semaine ?") LIRE (jour) message <- "Vous devez " + "prix" + " francs" ECRIRE (message) Saisie des données Calcul du prix Affichage du résultat">

La présentation est en train de télécharger. S'il vous plaît, attendez

La présentation est en train de télécharger. S'il vous plaît, attendez

Jean-Philippe PERNIN Université Stendhal Département Informatique Pédagogique Bureau I113 Mél. : Actions nommées, Procédures.

Présentations similaires


Présentation au sujet: "Jean-Philippe PERNIN Université Stendhal Département Informatique Pédagogique Bureau I113 Mél. : Actions nommées, Procédures."— Transcription de la présentation:

1 Jean-Philippe PERNIN Université Stendhal Département Informatique Pédagogique Bureau I113 Mél. : Actions nommées, Procédures et portée des variables

2 Copyright - Jean-Philippe Pernin - DIP - Université Stendhal - Grenoble 3 Programme = séquence d'actions Le programme principal décrit la séquence d'actions qui vont être exécutées. Le programme est écrit uniquement avec les termes ou les conventions autorisées dans le langage. Début Programme Action1 Action2.... Fin Programme

3 Copyright - Jean-Philippe Pernin - DIP - Université Stendhal - Grenoble 3 Comment gérer la complexité : exemple d'un programme long LEXIQUE age, taille, jour, prix : ENTIERS message : CHAINE DÉBUT PROGRAMME ECRIRE ('Quel est votre age ?") LIRE (age) ECRIRE ('Quel est votre taille ?") LIRE (taille) ECRIRE ('Quel est le jour de la semaine ?") LIRE (jour) SI (taille <= 100) ALORS prix <- 0 SINON SI (jour = "SA") OU (jour = "DI") ALORS prix <- 100 SINON SI (age > = 18) ALORS prix <- 100 SINON prix <- 60 FINSI message <- "Vous devez " + "prix" + " francs" ECRIRE (message) FIN PROGRAMME SI (taille <= 100) ALORS prix <- 0 SINON SI (jour = "SA") OU (jour = "DI") ALORS prix <- 100 SINON SI (age > = 18) ALORS prix <- 100 SINON prix <- 60 FINSI ECRIRE ('Quel est votre age ?") LIRE (age) ECRIRE ('Quel est votre taille ?") LIRE (taille) ECRIRE ('Quel est le jour de la semaine ?") LIRE (jour) message <- "Vous devez " + "prix" + " francs" ECRIRE (message) Saisie des données Calcul du prix Affichage du résultat

4 Copyright - Jean-Philippe Pernin - DIP - Université Stendhal - Grenoble 3 Gérer la complexité : concept d'action nommée Un programme trop long devient vite incompréhensible. On peut regrouper une suite d'instructions consécutives en un ensemble correspondant à une action "logique" de plus haut niveau : concept d'action nommée ou procédure ou sous-programme DÉBUT PROGRAMME FAIRE LireDonnées FAIRE CalculerPrix FAIRE AfficherPrix FIN PROGRAMME ACTION LireDonnées.../... FIN ACTION ACTION CalculerPrix.../... FIN ACTION ACTION AfficherPrix.../... FIN ACTION

5 Copyright - Jean-Philippe Pernin - DIP - Université Stendhal - Grenoble 3 Exemple de programme avec actions nommées LEXIQUE age, taille, jour, prix : ENTIERS message : CHAINE ACTION LireDonnees ECRIRE ('Quel est votre age ?") LIRE (age) ECRIRE ('Quel est votre taille ?") LIRE (taille) ECRIRE ('Quel est le jour de la semaine ?") LIRE (jour) FIN ACTION ACTION CalculerPrix SI (taille <= 100) ALORS prix <- 0 SINON SI (jour = "SA") OU (jour = "DI") ALORS prix <- 100 SINON SI (age > = 18) ALORS prix <- 100 SINON prix <- 60 FINSI FIN ACTION ACTION AfficherPrix message <- "Vous devez " + "prix" + " francs" ECRIRE (message) FIN ACTION DÉBUT PROGRAMME FAIRE LireDonnees FAIRE CalculerPrix FAIRE AfficherPrix FIN PROGRAMME ACTION CalculerPrix SI (taille <= 100) ALORS prix <- 0 SINON SI (jour = "SA") OU (jour = "DI") ALORS prix <- 100 SINON SI (age > = 18) ALORS prix <- 100 SINON prix <- 60 FINSI FIN ACTION ACTION LireDonnees ECRIRE ('Quel est votre age ?") LIRE (age) ECRIRE ('Quel est votre taille ?") LIRE (taille) ECRIRE ('Quel est le jour de la semaine ?") LIRE (jour) FIN ACTION ACTION AfficherPrix message <- "Vous devez " + "prix" + " francs" ECRIRE (message) FIN ACTION FAIRE LireDonnees FAIRE CalculerPrix FAIRE AfficherPrix DÉBUT PROGRAMME FIN PROGRAMME

6 Copyright - Jean-Philippe Pernin - DIP - Université Stendhal - Grenoble 3 Portée des variables : notion de variable globale LEXIQUE age, taille, jour, prix : ENTIERS message : CHAINE ACTION LireDonnees ECRIRE ('Quel est votre age ?") LIRE (age) ECRIRE ('Quel est votre taille ?") LIRE (taille) ECRIRE ('Quel est le jour de la semaine ?") LIRE (jour) FIN ACTION ACTION CalculerPrix SI (taille <= 100) ALORS prix <- 0 SINON SI (jour = "SA") OU (jour = "DI") ALORS prix <- 100 SINON SI (age > = 18) ALORS prix <- 100 SINON prix <- 60 FINSI FIN ACTION ACTION AfficherPrix message <- "Vous devez " + "prix" + " francs" ECRIRE (message) FIN ACTION DÉBUT PROGRAMME FAIRE LireDonnees FAIRE CalculerPrix FAIRE AfficherPrix ECRIRE (age) FIN PROGRAMME age Déclaration d'une variable déclarée au niveau global La variable est connue et utilisable : Dans le programme principal Dans chaque procédure (ou action nommée) age

7 Copyright - Jean-Philippe Pernin - DIP - Université Stendhal - Grenoble 3 Portée des variables : notion de variable locale LEXIQUE message : CHAINE ACTION LireDonnees LEXIQUE prenom, nom : CHAINE ECRIRE ('Quel est votre nom ?") LIRE (nom) ECRIRE ('Quel est votre prenom ?") LIRE (prenom) ECRIRE (nom) FIN ACTION ACTION AfficherIdentité message <- "Vous vous appelez " + prenom + " " + nom ECRIRE (message) FIN ACTION DÉBUT PROGRAMME FAIRE LireDonnees FAIRE AfficherIdentité ECRIRE (nom) FIN PROGRAMME Déclaration d'une variable au sein d'une procédure La variable est connue et utilisable au sein de la procédure ou elle a été déclarée nom La variable n'est pas utilisable dans le programme principal ou dans une autre procédure


Télécharger ppt "Jean-Philippe PERNIN Université Stendhal Département Informatique Pédagogique Bureau I113 Mél. : Actions nommées, Procédures."

Présentations similaires


Annonces Google