La présentation est en train de télécharger. S'il vous plaît, attendez

La présentation est en train de télécharger. S'il vous plaît, attendez

Lalgorithmique, les séquences. Séquences alternatives et itératives (répétitives). Notion de fonctions. Rénovation STG – Économie Gestion - Académie de.

Présentations similaires


Présentation au sujet: "Lalgorithmique, les séquences. Séquences alternatives et itératives (répétitives). Notion de fonctions. Rénovation STG – Économie Gestion - Académie de."— Transcription de la présentation:

1 Lalgorithmique, les séquences. Séquences alternatives et itératives (répétitives). Notion de fonctions. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

2 Les algorithmes : les séquences alternatives. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

3 Algorithme … Début | … | Si TEST SUR DONNEE Alors | | VALEUR SI VRAI | Sinon | | VALEUR SI FAUX | FinSi | … | Fin La déclaration des données variables et constantes. Le traitement. Algorithme avec séquence alternative. Séquence alternative : Même logique que le tableur ! = SI (Test ; valeur si vrai ; valeur si faux) Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

4 Algorithme n°04 Algorithme Algorithme03 Variable Prix : Entier / Variable Quantité : Entier / Variable Montant : Réel Variable Remise : Réel / Constante Taux1 < / Constante Taux2 < Début | Afficher ( "Nombre de produits commandés" ) | Saisir ( Quantité ) | Afficher ( "Prix unitaire" ) | Saisir ( Prix ) | Si ( Quantité * prix ) < 2000 Alors | | Remise <- Prix * Quantité * Taux1 | Sinon | | Remise <- Prix * Quantité * Taux2 | FinSi | Montant <- ( Prix * Quantité ) - remise | Afficher ( "Le montant dû est de ", MONTANT, " " ) | Afficher ( "Le montant de la remise est de ", Remise, " " ) Fin Si le montant de la commande est inférieure à 2000, alors (la remise est de 0,05 * montant) sinon (elle est de 0,10 * montant). Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

5 Algorithme avec séquences alternatives imbriquées. Nous sommes déjà hors programme ! Mais il est possible de concevoir des séquences alternatives imbriquées, tout comme avec Excel : | Si ( Quantité * prix ) < 2000 Alors | | Si ( Quantité * prix ) < 1000 Alors | | Remise <- Prix * Quantité * Taux1 | | Sinon | | Remise <- Prix * Quantité * Taux2 | | FinSi | Sinon | | Remise <- Prix * Quantité * Taux3 | FinSi | Montant <- ( Prix * Quantité ) - remise Déclaration des données Ne pas oublier de déclarer Taux3 et de lui affecter une valeur. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

6 Limites du programme. Cest avant tout la compréhension, linterprétation des algorithmes qui est objectif de formation. La séquence alternative doit donc être testée et comprise. Un algorithme peut être modifié par lélève, il peut donc être amené à ajouter une séquence alternative à un algorithme existant. Un algorithme présentant des structures alternatives imbriquées peut être présenté pour lecture et interprétation… mais un élève nest pas tenu de savoir le refaire. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

7 Les algorithmes : les séquences itératives. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

8 Algorithme avec séquence itérative (répétitive). Lorsquun algorithme répète plusieurs fois un même traitement, on parle de séquence itérative. Cette séquence itérative peut être conçue suivant plusieurs logiques : On répète le traitement TANT QUE une donnée renseignée par lutilisateur lautorise, TANT QUE il répond Oui à la question Continuer ? par exemple. On répète le traitement POUR un nombre de cycles donné. Pour I = 1 à n. On va REPETER le traitement JUSQUÀ ce quune donnée prenne une valeur précise. – Cet logique ressemble à la logique TANT QUE. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

9 Structure Tant Que / Fin Tant Que Algorithme Algorithme08 … Début | Afficher ( "Avez vous un traitement à effectuer ?" ) | Saisir ( Reponse ) | TantQue Reponse = "oui" Faire | | Afficher ( "Nombre de produits commandés" ) | | Saisir ( Quant ) | | Afficher ( "Prix unitaire" ) | | Saisir ( Prix ) | | Montant <- ( Prix * Quant * (1 + TVA )) | | Afficher ( "Le montant dû est de ", MONTANT, " TTC " ) | | Afficher ( "Avez vous un autre traitement à effectuer ?" ) | | Saisir ( Reponse ) | FinTantQue Fin La déclaration des données Le traitement. Le traitement est répété jusquà ce que la réponse diffère de oui ; attention à la saisie !

10 Algorithme Algorithme10 … Début | Afficher ( "Quel est le nombre de traitement à réaliser ?" ) | Saisir ( N ) | Pour I <- 1 à N Faire | | Afficher ( "Nombre de produits commandés" ) | | Saisir ( Quant ) | | Afficher ( "Prix unitaire" ) | | Saisir ( Prix ) | | Montant <- ( Prix * ( 1 + TVA ) * Quant ) | | Afficher ( "Le montant dû est de ", MONTANT, " TTC " ) | FinPour Fin La déclaration des données Le traitement. Structure Pour. Le traitement est répété N fois. N est une variable déclarée et affectée par lutilisateur La variable I est un compteur qui sincrémente à chaque passage. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

11 Algorithme Algorithme12 … Début | Afficher ( "Tapez 0 pour terminer le traitement" ) | Répéter | | Afficher ( "Nombre de produits commandés" ) | | Saisir ( Quant ) | | Afficher ( "Prix unitaire" ) | | Saisir ( Prix ) | | Si ( Quant * prix ) < 2000 Alors | | | Remise <- Prix * Quant * Taux1 | | Sinon | | | Remise <- Prix * Quant * Taux2 | | FinSi | | Montant <- ( ( Prix * Quant ) - remise ) * ( 1 + TVA ) | | Afficher ( "Le montant dû est de ", MONTANT, " " ) | | Afficher ( "Le montant HT de la remise est de ", Remise, " " ) | Jusqu'à Quant = 0 Fin La déclaration des données Le traitement. Structure Répéter / Jusquà. Le traitement va être répété jusquà ce que lutilisateur saisisse 0 pour les quantités. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

12 Limites du programme. Cest avant tout la compréhension, linterprétation des algorithmes qui est objectif de formation. La séquence itérative doit donc être testée et comprise. Vu le temps imparti, une seule structure doit être assimilée par lélève. Il pourra reproduire cette structure dans des exercices. En revanche, un algorithme présentant dautres structures peut être présenté pour lecture et interprétation… mais un élève nest pas tenu de savoir le refaire. Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

13 Quelques ressources Internet… CRDP de GRENOBLE : le lien pour se procurer le logiciel Pratiquer lalgorithme : licence établissement. Réseau CERTA. ATELIER TICE GESTION : le site de Frédéric Redonnet. NETALYA : le portail des nouvelles technologies. Page ALGOR : quelques exemples dalgorithmes… complexes ! Il existe une multitude de sites consacrés aux algorithmes ! Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005

14 Et pour terminer ? Algorithme Algorithme final … Début | Afficher ( " Connaissez-vous les algorithmes ?" ) | Saisir ( Reponse ) | TantQue Reponse = "non" | | Afficher Diaporama | | Afficher ( "Avez-vous compris ou doit-on faire une nouvelle itération ?" ) | | Saisir ( Reponse ) | FinTantQue Fin Rénovation STG – Économie Gestion - Académie de Lille – Mars 2005


Télécharger ppt "Lalgorithmique, les séquences. Séquences alternatives et itératives (répétitives). Notion de fonctions. Rénovation STG – Économie Gestion - Académie de."

Présentations similaires


Annonces Google