La présentation est en train de télécharger. S'il vous plaît, attendez

La présentation est en train de télécharger. S'il vous plaît, attendez

Exercices Algorithmiques. Structure Itérative Exercice Écrire un algorithme qui demande à lutilisateur un nombre compris entre 1 et 3 jusquà ce que la.

Présentations similaires


Présentation au sujet: "Exercices Algorithmiques. Structure Itérative Exercice Écrire un algorithme qui demande à lutilisateur un nombre compris entre 1 et 3 jusquà ce que la."— Transcription de la présentation:

1 Exercices Algorithmiques

2 Structure Itérative Exercice Écrire un algorithme qui demande à lutilisateur un nombre compris entre 1 et 3 jusquà ce que la réponse convienne.

3 Début Variable N : Entier N 0 Saisir Entrez un nombre entre 1 et 3; N TantQue N 3 Faire Afficher Saisie erronée. Recommencez Saisir Entrez un nombre entre 1 et 3; N FinTq Fin

4 Exercice Écrire un algorithme qui demande un nombre compris entre 10 et 20, jusquà ce que la réponse convienne. En cas de réponse supérieure à 20, on fera apparaître un message : « Plus petit ! », et inversement, « Plus grand ! » si le nombre est inférieur à 10.

5 Debut Variable N : Entier N 0 Saisir Entrez un nombre entre 10 et 20 ; N TantQue N 20 Faire Si N < 10 Alors Afficher Plus grand ! Sinon Afficher Plus petit ! Finsi Saisir Entrez un nombre entre 10 et 20 ; N FinTantQue Fin

6 Exercice Écrire un algorithme qui demande un nombre de départ, et qui ensuite affiche les dix nombres suivants. Par exemple, si l'utilisateur entre le nombre 17, le programme affichera les nombres de 18 à 27.

7 Début Variables N, i : Entier Saisir Entrez un nombre : ; N Afficher Les 10 nombres suivants sont : Pour i = N + 1 à N + 10 Afficher i Fin Pour équivalent à (i i+1) Fin

8 Écrire un algorithme qui demande un nombre de départ, et qui ensuite écrit la table de multiplication de ce nombre, présentée comme suit (cas où l'utilisateur entre le nombre 7) : Table de 7 : 7 x 1 = 7 7 x 2 = 14 7 x 3 = 21 … 7 x 10 = 70

9 Debut Variables N, i : Entier Saisir Entrez un nombre : ; N Ecrire La table de multiplication de ce nombre est : Pour i = 1 à 10 Afficher N;x;i; = ; N*i Fin Pour Fin

10 Ecrire un algorithme qui demande un nombre de départ, et qui calcule la somme des entiers jusquà ce nombre. Par exemple, si lon entre 5, le programme doit calculer : = 15

11 Debut Variables N, i, Somme : Entier Saisir Entrez un nombre : ; N Somme 0 Pour i = 1 à N Somme Somme + i Fin Pour Afficher La somme est :, Somme Fin

12 Ecrire un algorithme qui demande un nombre de départ, et qui calcule sa factorielle. NB : la factorielle de 8, notée 8 !, vaut 1 x 2 x 3 x 4 x 5 x 6 x 7 x 8

13 Debut Variables N, i, F : Entier Saisir Entrez un nombre : ; N F 1 Pour i = 2 à N F F * i Fin Pour Afficher La factorielle est :, F Fin

14 Écrire un algorithme qui demande successivement 5 nombres à lutilisateur, afin de déterminer quel était le plus grand parmi ces 5 nombres : Entrez le nombre numéro 1 : 12 Entrez le nombre numéro 2 : 14 Etc. Entrez le nombre numéro 5 : 6 Le plus grand de ces nombres est : 14 Modifiez ensuite lalgorithme pour que le programme affiche de surcroît en quelle position avait été saisie ce nombre : Cétait le nombre numéro 2

15 Début Variables N, i, PG : Entier PG <- 0 Pour i <- 1 à 20 Saisir Entrez un nombre : ; i; =; N Si N > PG Alors PG <- N FinSi Fin Pour Ecrire Le nombre le plus grand était :, PG Fin

16 Version Améliorée Début Variables N, i, PG, IPG : Entier PG 0 Pour i 1 à 5 Saisir Entrez un nombre : ; N Si N > PG Alors PG N IPG i FinSi Fin Pour Ecrire Le nombre le plus grand était :, PG Ecrire Il a été saisi en position numéro, IPG Fin

17 Réécrire lalgorithme précédent, mais cette fois-ci on ne connaît pas davance combien lutilisateur souhaite saisir de nombres. La saisie des nombres sarrête lorsque lutilisateur entre un zéro.

18 Début Variables N, i, PG, IPG : Entier N 1 i 1 PG <- 0 TantQue N <> 0 Saisir Entrez un nombre : ; N Si N > PG Alors PG N IPG i FinSi i i + 1 FinTantQue Ecrire Le nombre le plus grand était :, PG Ecrire Il a été saisi en position numéro, IPG Fin

19 Lire la suite des prix (en euros entiers et terminée par zéro) des achats dun client. Calculer la somme quil doit, lire la somme quil paye, et simuler la remise de la monnaie en affichant les textes « 10 E », « 5 E » et « 1 E » autant de fois quil y a de coupures de chaque sorte à rendre.

20 Début VariablesMT, somdue, MV, IPG, Reste, Nb10, Nb5 : Entier MT 1 somdue <- 0 TantQue MT <> 0 Saisir Entrez le montant : ; MT somdue somdue + MT FinTantQue Afficher Vous devez :,MT Saisir Montant versé :; MV Reste MV – MT Nb10 0 TantQue Reste >= 10 Nb10 Nb Reste Reste – 10 FinTantQue Nb5 0 Si Reste >= 5 Nb5 1 Reste Reste – 5 FinSi Ecrire Rendu de la monnaie : Ecrire Pièces de 10 E :, Nb10 Ecrire Pièces de 5 E:, Nb5 Ecrire Pièces de 1 E :, reste Fin

21 Fin de cette Partie

22 - Les Tableaux et Vecteurs

23 Écrire un algorithme qui déclare et remplisse un Vecteur de 7 valeurs numériques en les mettant toutes à zéro.

24 Tableau Truc(7), i : Entier Debut dim truc(7) as Integer Pour i 0 à 6 For i = 0 to 6 Truc(i) 0 truc(i) = 0 Fin Pour next i Fin

25 Écrire un algorithme qui déclare et remplisse un vecteur contenant les six voyelles de lalphabet latin.

26 Tableau Truc(6) : Chaine Debut Truc(0) a Truc(1) e Truc(2) i Truc(3) o Truc(4) u Truc(5) y Fin

27 Ecrire un algorithme qui déclare un tableau de 9 notes, dont on fait ensuite saisir les valeurs par lutilisateur.

28 Début Tableau Notes(9) : Entier Variable i : Entier Pour i 0 à 8 Saisir "Entrez la note numéro ", i + 1; Notes(i) Fin Pour Fin

29 Que produit lalgorithme suivant ? Début Tableau Nb(6) : Entier Variable i : Entier Pour i 0 à 5 Nb(i) i * i Fpour Pour i 0 à 5 Afficher Nb(i) Finpour Fin

30 Cet algorithme remplit un tableau avec six valeurs : 0, 1, 4, 9, 16, 25. Il les écrit ensuite à lécran.

31 Que produit lalgorithme suivant ? Début Tableau N(7) : Entier Variables i, k : Entier N(0) 1 Pour k 1 à 6 N(k) N(k-1) + 2 FinPour Pour i 0 à 6 Afficher N(i) FinPour Fin

32 Cet algorithme remplit un tableau avec les sept valeurs : 1, 3, 5, 7, 9, 11, 13. Il les écrit ensuite à lécran

33 Que produit lalgorithme suivant ? Début Tableau Suite(7) : Entier Variable i en Entier Suite(0) 1 Suite(1) 1 Pour i 2 à 6 Suite(i) Suite(i-1) + Suite(i-2) Fin Pour Pour i 0 à 6 Afficher Suite(i) Fin Pour Fin

34 Cet algorithme remplit un tableau de 7 valeurs : 1, 1, 2, 3, 5, 8, 13

35 Vecteur etTableaux dynamiques Il arrive fréquemment que lon ne connaisse pas à lavance le nombre déléments que devra comporter un tableau. Bien sûr, une solution consisterait à déclarer un tableau gigantesque. Mais dune part, on nen sera jamais parfaitement sûr, dautre part, en raison de limmensité de la place mémoire réservée – et la plupart du temps non utilisée, cest un gâchis préjudiciable à la rapidité, voire à la viabilité, de notre algorithme. Aussi, pour parer à ce genre de situation, a-t-on la possibilité de déclarer le tableau sans préciser au départ son nombre déléments. Ce nest que dans un second temps, au cours du programme, que lon va fixer ce nombre via une instruction de dimensionnement : Redim. Notez que tant quon na pas précisé le nombre déléments dun tableau, dune manière ou dune autre, ce tableau est inutilisable. Ex: Tableau Notes() : Entier Variable nb en Entier Saisir Combien y a-t-il de notes à saisir ?, nb Redim Notes(nb)

36 Ecrivez un algorithme permettant à lutilisateur de saisir un nombre quelconque de valeurs, qui devront être stockées dans un tableau. Lutilisateur doit donc commencer par entrer le nombre de valeurs quil compte saisir. Il effectuera ensuite cette saisie. Enfin, une fois la saisie terminée, le programme affichera le nombre de valeurs négatives et le nombre de valeurs positives.

37 Debut Variables Nb, Nbpos, Nbneg en Entier Tableau T() : Entier Saisir Entrez le nombre de valeurs :; NB Redim T(Nb) Nbpos 0 Nbneg 0 Pour i 0 à Nb - 1 Saisir Entrez le nombre n°, T(i) Si T(i) > 0 alors Nbpos Nbpos + 1 Sinon si T(i) <0 alors Nbneg Nbneg + 1 Finsi Fin Pour Ecrire Nombre de valeurs positives :, Nbpos Ecrire Nombre de valeurs négatives :, Nbneg Fin

38 Ecrivez un algorithme calculant la somme des valeurs dun tableau (on suppose que le tableau a été préalablement saisi). on ne programme pas la saisie du tableau, dont on suppose quil compte N éléments Tableau T() : Entier

39 Variables i, Som, N : Entier Tableau T() : Entier Saisir Entrez le nombre de valeurs :; N Redim T(N) … Som 0 Pour i 0 à N - 1 Som Som + T(i) Fin Pour Ecrire Somme des éléments du tableau :, Som Fin

40 Écrivez un algorithme constituant un tableau, à partir de deux tableaux de même longueur préalablement saisis. Le nouveau tableau sera la somme des éléments des deux tableaux de départ. (on suppose que T1 et T2 comptent N éléments, et quils sont déjà saisis) EX : Tableaux T1(), T2(), T3() en Entier Exemple : Tableau 1 : 4 – 8 – 7 – 9 – 1 – 5 – 4 – 6 Tableau 2 : 7 – 6 – 5 – 2 – 1 – 3 – 7 – 4 Tableau à constituer : 11 – 14 – 12 – 11 – 2 – 8 –

41 Debut Variables i, N en Entier Tableaux T1(), T2(), T3() en Entier … (on suppose que T1 et T2 comptent N éléments, et quils sont déjà saisis) Redim T3(N) … Pour i 0 à N - 1 T3(i) T1(i) + T2(i) Afficher T3(I) Fpour Fin

42 Toujours à partir de deux tableaux précédemment saisis, écrivez un algorithme qui calcule le Gone des deux tableaux. Pour calculer le Gone, il faut multiplier chaque élément du tableau 1 par chaque élément du tableau 2, et additionner le tout. Exemple : Tableau 1 : 4 – 8 – Tableau 2 : 3 – 6 Le Gone : 3*4 + 3*8 + 3*7 + 3*12 + 6*4 + 6*8 + 6*7 + 6*12 = 279

43 Début Variables i, j, N1, N2, S en Entier Tableaux T1(), T2() en Entier N1 2 N2 4 … On ne programme pas la saisie des tableaux T1 et T2. On suppose que T1 possède N1 éléments, et que T2 en possède N2 éléments … S <- 0 Pour i 0 à N1 – 1 soit (1) Pour j 0 à N2 – 1 soit (3) S S + T1(i) * T2(j) Fin Pour Ecrire "Le Gone est de : ", S Fin

44 Ecrivez un algorithme qui permette la saisie dun nombre quelconque de valeurs, Toutes les valeurs doivent être ensuite augmentées de 1, et le nouveau tableau sera affiché à lécran. Lutilisateur déterminera la taille du vecteur

45 Debut Variables Nb, i : Entier Tableau T() : Entier Saisir Entrez le nombre de valeurs : ; Nb Redim T(Nb ) Pour i 0 à Nb - 1 Saisir Entrez le nombre n°, i; T(I) +1 Fin Pour Afficher "Nouveau tableau :" Pour i <- 0 à Nb – 1 T(i) <- T(i) + 1 ( autre solution A supprimer éventuellement ) Afficher T(i) Finpour Fin

46 Ecrivez un algorithme permettant, toujours sur le même principe, à lutilisateur de saisir un nombre déterminé de valeurs. Le programme, une fois la saisie terminée, renvoie la plus grande valeur en précisant quelle position elle occupe dans le tableau. On prendra soin deffectuer la saisie dans un premier temps, et la recherche de la plus grande valeur du tableau dans un second temps.

47 Variables Nb, Posmaxi : Entier Tableau T() en Entier Saisir Entrez le nombre de valeurs :; Nb Redim T(Nb) Pour i 0 à Nb - 1 Saisir Entrez le nombre n°, i + 1; T(i) Fin Pour Posmaxi 0 Pour i 1 à Nb - 1 Si T(i) > T(Posmaxi) alors Posmaxi i Finsi Fin Pour Ecrire Element le plus grand :, T(Posmaxi) Ecrire Position de cet élément :, Posmaxi Fin

48 Toujours et encore sur le même principe, écrivez un algorithme permettant, à lutilisateur de saisir les notes d'une classe. Le programme, une fois la saisie terminée, renvoie le nombre de ces notes supérieures à la moyenne de la classe.

49 Debut Variables Nb, i, Som, Moy, Nbsup : Entier Tableau T() en Entier Saisir Entrez le nombre de notes à saisir : ; Nb Redim T(Nb ) Pour i 0 à Nb - 1 Saisir Entrez le nombre n°, i + 1 FinPour Som 0 Pour i 0 à Nb - 1 Som Som + T(i) Fin Pour Moy Som / Nb NbSup 0 Pour i <- 0 à Nb - 1 Si T(i) > Moy Alors NbSup - NbSup + 1 FinSi Fin Pour Ecrire NbSup, " élèves dépassent la moyenne de la classe" Fin

50 Fin De cette Partie


Télécharger ppt "Exercices Algorithmiques. Structure Itérative Exercice Écrire un algorithme qui demande à lutilisateur un nombre compris entre 1 et 3 jusquà ce que la."

Présentations similaires


Annonces Google